Nuke 9.0 licensing and speed shenanigans

loocas | Nuke,software,technical | Wednesday, November 26th, 2014

nuke_studio_banner

If you’ve upgraded to Nuke 9.0 or even Nuke Studio, like I did, recently, you might’ve bumped into some licensing and boot-up issues with Nuke. So, allow me to share my experience with this upgrade.

First off, Nuke 9.0 is just fabulous. I’m really in love with the software, even though there are a few issues I’m having from time to time. So, after upgrading to NukeX and Nuke Studio 9.0 I also had to update my licenses and with that, the license server. I’m not sure whether The Foundry completely abandoned the FLEXlm license server, or not, but I transferred all my licenses to the newer RLM licensing scheme. With that came a few issues. The most notable one was that Nuke simply did not start up. Easy fix:

  • Stop the foundry FLEXlm server
  • Uninstall any older FLT software, completely, delete your old licenses, especially from the C:\ProgramData\The Foundry\RLM and C:\Program Files\The Foundry\RLM locations on your license server
  • Install the latest version of the FLT software
  • Run the FLT tool and drag-drop the newest license in there. It should install automatically for you.
  • Restart the RLM server

license_server_status

Now this worked. Nuke started booting up, but it took terribly, terribly long. I mean, Nuke 8.xx took about 2-3 seconds to check for the license on my server (via VPN) and boot up. Nuke 9.0v1 took over 20 seconds (!!!) to check for the license and even longer (!!!) for Nuke Studio to fire up.

Something was wrong and I wasn’t sure what. All I suspected was that my setup was acting up as I’m sure The Foundry would’ve done something about this if it were a bug.

And sure enough! I found the issue.

(more…)

Powered by WordPress | Theme by Roy Tanck